Bug 61898

Summary: Quick Guide is getting a bit out of date
Product: POI Reporter: Mark Murphy <jmarkmurphy>
Component: SS CommonAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: enhancement CC: si3012
Priority: P2    
Version: 4.0.x-dev   
Target Milestone: ---   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 59836    

Description Mark Murphy 2017-12-13 14:49:40 UTC
It has come to my attention that the Quick Guide for HSSF/XSSF is getting a bit out of date, particularly with respect to deprecations in the last several releases. Maybe someone should go through it thoroughly and update with current best practices/new Enums, etc.
Comment 1 Javen O'Neal 2017-12-13 18:25:58 UTC
I'll update the enums.

Side note: If we ever want to prioritize it, we could generate our quick guide from compiled and tested example code. Tika does this.
This would allow refactoring tools in IDE's to be able to keep the documentation up to date with the latest deprecations.
Comment 2 Javen O'Neal 2017-12-13 18:37:18 UTC
Other changes:
short -> int
Comment 3 Javen O'Neal 2017-12-13 18:47:01 UTC
BorderStyle: r1818054
Comment 4 Nick Burch 2017-12-13 19:22:23 UTC
For Apache Tika, all the examples on the website are pulled in from java programs stored in the examples area, which area unit tested. It wouldn't be too much work to do something similar, but likely would need some custom Forest plugin.

Otherwise, some bits of the howto are also available in the POI examples area, eg src/org/apache/poi/xssf/eventusermodel/examples/FromHowTo.java, maybe we could look to do that more?
Comment 5 Javen O'Neal 2018-02-05 01:30:52 UTC
*** Bug 62075 has been marked as a duplicate of this bug. ***
Comment 6 Javen O'Neal 2018-02-12 06:21:27 UTC
HorizontalAlignment and VerticalAlignment: r1823922
Comment 7 Javen O'Neal 2018-02-12 06:27:56 UTC
FillPattern: r1823924
Comment 8 Javen O'Neal 2018-02-12 06:42:55 UTC
short -> int: r1823925
Comment 9 Javen O'Neal 2018-02-12 06:52:26 UTC
republished site: r1823926.

I don't see any other CellStyle constants that were replaced with enums.

There are probably some newer POI and Java idioms (Java 8: try-with-resources) that could be updated.
Comment 10 Javen O'Neal 2018-02-12 06:57:58 UTC
(In reply to Javen O'Neal from comment #9)
> I don't see any other CellStyle constants that were replaced with enums.
...in the latest Spreadsheet Quick Guide. So the Quick Guide is up-to-date with respect to enums.
Comment 11 Dominik Stadler 2018-04-05 19:58:55 UTC
I did some more changes, mostly simple try-with-resources. I don't think we should put everything under strict Java 8 usage as that would make the sample-code less easy to read, these are code-snippets anyway.

I am closing this as fixed for now as the main purpose is done, we will adjust the guides some more as we go along anyway.
Comment 12 Dominik Stadler 2018-04-05 19:59:25 UTC
Latest changes are at r1828472