Bug 61928

Summary: Incorrext XLSB extraction
Product: POI Reporter: grimmreaperph <grimmreaperph>
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED LATER    
Severity: enhancement    
Priority: P2    
Version: 3.17-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description grimmreaperph 2017-12-26 04:29:25 UTC
Supposed I have a Sample.xlsb file that contains the ff data:

--
         colA    colB    colC    colD
row1     value0  value1          value3
--

When extracted using XSSFBEventBasedExcelExtractor via getText(), output is:

--
         colA    colB    colC    colD
row1     value0  value1  value3
--
Comment 1 grimmreaperph 2017-12-26 04:33:46 UTC
Now the colD data is missing because the XSSFBEventBasedExcelExtractor -> getText() didn't leave the colC empty.
Comment 2 Dominik Stadler 2018-02-08 19:54:28 UTC
Can you provide sample files and code that shows the problem to make it possible for others to reproduce the described behavior?
Comment 3 Tim Allison 2018-02-08 21:19:17 UTC
Does this behavior differ from XSSFEventBasedExcelExtractor?
Comment 4 Dominik Stadler 2018-04-05 19:38:08 UTC
We cannot analyze or reproduce this without more information, please reopen this bug if it is still a problem for you and you can provide some sample files and sample-code/unit-tests which reproduce this problem.