Bug 61942

Summary: Refactor PackagePartName handling and add getUnusedPartIndex method
Product: POI Reporter: Andreas Beeker <kiwiwings>
Component: OPCAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 4.0.x-dev   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Andreas Beeker 2017-12-31 00:52:20 UTC
While working on the ObjectData interface for SL Common, I wanted to have a central method to request a new resource, i.e. a new file name with a unique index - this lead to the new method OPCPackage.getUnusedPartIndex(...)

As I had to work with PackagePartNames, I've realized that the current implementation carries around the errorFlag a lot instead of an appropriate control flow - so I also eliminated that.

And in PackagePartCollection its better to use a sorted TreeMap.
Comment 1 Andreas Beeker 2017-12-31 00:56:55 UTC
applied via r1819708