Bug 62301

Summary: IOException Unable to unwrap data in versions after
Product: Tomcat 8 Reporter: djohnson
Component: WebSocketAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: major    
Priority: P2    
Version: 8.5.29   
Target Milestone: ----   
Hardware: PC   
OS: All   

Description djohnson 2018-04-13 22:28:00 UTC
We are running into the following error where we are unable to establish a websocket connection using .Net:

java.io.IOException: Unable to unwrap data, invalid status [CLOSED]

This is working on Tomcat 8.0.x

This is not working for Tomcat version 8.5.x and 9.0.x (i.e. versions later than 8.5.x)
Comment 1 Remy Maucherat 2018-04-17 09:55:30 UTC
Please provide a test case if it is endpoint dependent, and the Tomcat configuration used.
Comment 2 Mark Thomas 2018-04-23 14:17:45 UTC
I'm seeing some failures with the Autobahn test suite and a clean build of Tomcat trunk. I'm investigating...
Comment 3 Mark Thomas 2018-04-23 15:24:41 UTC
Failures appear to be related to r1807686
Still investigating...
Comment 4 Mark Thomas 2018-04-23 18:49:34 UTC
I'm resolving this on the basis the errors I was seeing in Autobahn were the cause of the reported problems.

If the error is still observed, please re-open with a test case that demonstrates the issue.

Fixed in:
- trunk for 9.0.8 onwards
- 8.5.x for 8.5.31 onwards
- 8.0.x for 8.0.52 onwards
- 7.0.x for 7.0.87 onwards