Bug 62450

Summary: Note change in SSI set will no longer HTML decode by default for users migrating to 2.4.x
Product: Apache httpd-2 Reporter: Hank Ibell <hwibell>
Component: DocumentationAssignee: HTTP Server Documentation List <docs>
Status: NEW ---    
Severity: minor Keywords: PatchAvailable
Priority: P2    
Version: 2.5-HEAD   
Target Milestone: ---   
Hardware: PC   
OS: Mac OS X 10.1   
Attachments: Proposed patch for trunk

Description Hank Ibell 2018-06-13 17:29:22 UTC
Add a note that the SSI set will no longer do HTML decoding between 2.2.x and 2.4.x.

Users that have an SSI page like the following would notice encoded entities in their response when migrating from 2.2.x to 2.4.x:

<!--#set var="message_entity" value="&lt;Hello &amp; goodbye!&gt;" -->
<p><!--#echo var="message_entity" --></p>

For example, the response they would see in 2.2.x would be:
<Hello & goodbye!>

while the response they would see in 2.4.x:
&lt;Hello &amp; goodbye!&gt;
Comment 1 Hank Ibell 2018-06-13 17:29:48 UTC
Created attachment 35964 [details]
Proposed patch for trunk