Bug 62718

Summary: Could not open old document due to unsaved content type.
Product: POI Reporter: pouponbe
Component: OPCAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: regression    
Priority: P2    
Version: 3.17-FINAL   
Target Milestone: ---   
Hardware: All   
OS: All   
Bug Depends on: 62717    
Bug Blocks:    

Description pouponbe 2018-09-13 16:50:58 UTC
As described in defect 62717 content type aren't always saved, it leads to unloadable document using org.apache.poi.openxml4j.opc.OPCPackage.openOrCreate(File) api.
Comment 1 PJ Fanning 2018-09-13 19:26:35 UTC
@pouponbe you marked this as a regression but didn't indicate what version this worked in
Comment 2 pouponbe 2018-09-14 12:55:50 UTC
It works with version 3.10.1.
Comment 3 Dominik Stadler 2019-12-15 12:56:36 UTC
Seems to report the same as bug 62717 anyway so not much use in keeping two bugs open for the same thing.

*** This bug has been marked as a duplicate of bug 62717 ***