Bug 63194

Summary: Tomcat 7.0.93: org.apache.tomcat.util.net.TestClientCertTls13: UnsatisfiedLinkError
Product: Tomcat 7 Reporter: Konstantin Kolinko <knst.kolinko>
Component: ConnectorsAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: minor    
Priority: P2    
Version: 7.0.93   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: TEST-org.apache.tomcat.util.net.TestClientCertTls13.APR.txt

Description Konstantin Kolinko 2019-02-21 11:06:46 UTC
Created attachment 36450 [details]
TEST-org.apache.tomcat.util.net.TestClientCertTls13.APR.txt

Testing Tomcat 7.0.93, when running with APR connector and with Java 11, test org.apache.tomcat.util.net.TestClientCertTls13 fails in a strange way:

java.lang.UnsatisfiedLinkError: org.apache.tomcat.jni.SSL.version()I

At the same time:

1. Smoke testing with Java 11 is OK,
2. Other TLS tests with java 11 are OK.
3. When running with Java 8 and older all tests in this test class are skipped.

So only a single test class is affected.

I guess that maybe the test does not initialize tomcat-native library properly (does not call AprLifecycleListener before calling SSL.version() ?)

Running the same test with current Tomcat 9 trunk (@r1854030) is OK. So maybe this issue has already been fixed in trunk.

Steps to reproduce:
1. Put tcnative-1.dll (64-bit) into bin/native/
2. set JAVA_HOME=path to java6 home
3. Edit build.properties file to be
---
java.7.home=<path to java11 home (64-bit)>
test.entry=org.apache.tomcat.util.net.TestClientCertTls13
---
4. Run the tests.
5. The exception is logged in TEST-org.apache.tomcat.util.net.TestClientCertTls13.APR.txt file. A copy of this file is attached to this bug report.
Comment 1 Mark Thomas 2019-03-01 16:58:00 UTC
Caused by various configuration issues.

Fixed in 7.0.x for 7.0.94 onwards.