Bug 63375

Summary: Error writing SXSSF workbook to a new .xlsx file
Product: POI Reporter: aespinosag.gfi
Component: SXSSFAssignee: POI Developers List <dev>
Status: RESOLVED LATER    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: Method that produces Rule M2.4 exception

Description aespinosag.gfi 2019-04-23 07:10:23 UTC
Created attachment 36544 [details]
Method that produces Rule M2.4 exception

So I'm trying to generate a new file with the content already filtered from an existing SXSSF workbook (deleting rows that don't match with the JSON query), but when I call the method used to write the content from filtered SXSSF workbook to the new .xlsx file generated (via getReportFile() method) it throws Rule M2.4 exception at workbook.write(fos);
Comment 1 Dominik Stadler 2019-04-23 20:32:03 UTC
Please try to provide a more self-sufficient code-example which reproduces the problem, your snippet here is not showing enough to allow to actually reproduce any problem. 
Ideally as a unit-test so we can add the test to our set of tests and ensure the problem stays fixed.
Comment 2 Dominik Stadler 2019-06-20 08:40:43 UTC
We cannot reproduce/fix this without more information.