Bug 63667

Summary: AH00051: child pid 28416 exit signal Segmentation fault
Product: Apache httpd-2 Reporter: abhishek.patil
Component: AllAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: NEEDINFO ---    
Severity: critical    
Priority: P2    
Version: 2.4.39   
Target Milestone: ---   
Hardware: Other   
OS: Linux   
Attachments: Contains Apache configurations and gdb bt full
Contains Apache configurations and gdb trace
Detailed backtrace

Description abhishek.patil 2019-08-15 11:04:31 UTC
We were facing segmentation fault with 2.4.39 and now also getting same error with this latest 2.4.41 version

Below is the error we are getting,
[Thu Aug 15 11:36:39.942478 2019] [core:notice] [pid 14702:tid 47528871867744] AH00051: child pid 28416 exit signal Segmentation fault (11), possible coredump in /apache/instance/home/path/

We are using Apache with below supporting binaries on RHEL 6.10 (Santiago).

•	apr-1.7.0
•	apr-util-1.6.1
•	pcre-8.43
•	openssl-1.1.1c
•	mod_cluster-1.3.1
•	httpd-2.4.41
Comment 1 Eric Covener 2019-08-15 11:06:56 UTC
Can you share your configuration and backtraces from the core?

Comment 2 abhishek.patil 2019-08-15 11:24:33 UTC
Created attachment 36719 [details]
Contains Apache configurations and gdb bt full
Comment 3 Eric Covener 2019-08-15 11:29:44 UTC
Can you share the `thread apply all bt full` output too?
Comment 4 abhishek.patil 2019-08-15 11:34:07 UTC
Created attachment 36720 [details]
Contains Apache configurations and gdb trace
Comment 5 abhishek.patil 2019-08-15 11:40:51 UTC
Created attachment 36721 [details]
Detailed backtrace
Comment 6 Eric Covener 2019-08-15 11:47:49 UTC
It looks like you are attaching to a running process rather than getting info from the core file.
Comment 7 abhishek.patil 2019-08-15 11:53:55 UTC
I can't see any core file getting generated but logs are getting filled with said errors and child processes are getting closed and new processes are getting spawned continuously.

I have also added below directive to generate core dumps in specific file but still not core dump file getting generated.

CoreDumpDirectory /app/test/conf

I can confirm that lots of disk space is available on server and there isn't any permission issue as well.
Comment 8 Eric Covener 2019-08-15 12:04:22 UTC
CoreDumpDirectory only has affect of /proc/sys/kernel/core_pattern isn't absolute or a pipe because CoreDumpDirectory is really just "the working directory during fatal signal".  /proc/sys/kernel/core_pattern may be sending cores elsewhere or to a program that filters them (saves only a few, sends them off somewhere remote, etc)
Comment 9 abhishek.patil 2019-08-15 12:18:06 UTC
I am not that expert on OS level stuff but this is what we have on hosting server. If that helps,

[http@server-hostname conf]$ cat /proc/sys/kernel/core_pattern
|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e
Comment 10 abhishek.patil 2019-08-15 12:27:25 UTC
Also I have checked inside /app and /var, no core dump file any where.