Bug 63675

Summary: Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl
Product: POI Reporter: xiao yuan <dandinghe202>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description xiao yuan 2019-08-20 13:31:21 UTC
The class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl.MaxOccursImpl does not override the enumValue () and set () methods in the org.apache.xmlbeans.impl.xb.xsdschema.AllNNI.Members class.The same is true in the class AllNNIImpl....Request Solution!
Comment 1 Dominik Stadler 2019-08-20 16:00:55 UTC
Sorry, but this way your bug-report is not very useful, without a clear way how to reproduce we will only be able to set it to "CANNOT REPRODUCE".

How do you try to compile it? What exact steps are necessary to reproduce the problem? ...

And is this only related to XMLBeans and not Apache POI? Then please report this at http://issues.apache.org/jira/secure/BrowseProject.jspa?id=10436 instead.

And please remember that this is a fully community project without anybody being paid to work on, so "requesting a solution" is not the best way to ask for help here...
Comment 2 xiao yuan 2019-08-21 01:03:01 UTC
(In reply to Dominik Stadler from comment #1)
> Sorry, but this way your bug-report is not very useful, without a clear way
> how to reproduce we will only be able to set it to "CANNOT REPRODUCE".
> 
> How do you try to compile it? What exact steps are necessary to reproduce
> the problem? ...
> 
> And is this only related to XMLBeans and not Apache POI? Then please report
> this at http://issues.apache.org/jira/secure/BrowseProject.jspa?id=10436
> instead.
> 
> And please remember that this is a fully community project without anybody
> being paid to work on, so "requesting a solution" is not the best way to ask
> for help here...

Yes,I'm trying to compile XMLBeans and moving Apache POI to Android OS.When I optimized the source code(XMLBeans), Android studio reported errors.The same problem has also been found in many classes under package org.apache.xmlbeans.impl.xb.xsdschema.impl*.
Comment 3 xiao yuan 2019-08-24 07:51:44 UTC
I'm sorry!That was my mistake.I deleted the method marked as deprecated in the base class org.apache.xmlbeans.impl.values.XmlObjectBase, while the corresponding methods in some interfaces were not marked deprecated.