Bug 63706

Summary: Sending http request to https endpoint logs SEVERE in tomcat 9.0.24
Product: Tomcat 9 Reporter: senthalan <senthalan>
Component: ConnectorsAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: user.ranita
Priority: P2    
Version: 9.0.24   
Target Milestone: -----   
Hardware: PC   
OS: Linux   

Description senthalan 2019-08-29 09:36:00 UTC
When sending an http request to https endpoint logs the following SEVERE in tomcat 9.0.24,


29-Aug-2019 13:34:40.088 SEVERE [https-jsse-nio-8443-exec-10] org.apache.coyote.AbstractProtocol$ConnectionHandler.process Error reading request, ignored
java.lang.NullPointerException
at org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.getSslSupport(NioEndpoint.java:1392)
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:853)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1593)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at org.apache.tomcat.util.threads.TaskThre

Here is my connector configuration,

    <Connector port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol"
               maxThreads="150" SSLEnabled="true">
        <SSLHostConfig>
            <Certificate certificateKeystoreFile="conf/wso2carbon.jks"
certificateKeystorePassword="wso2carbon"
                         type="RSA" />
        </SSLHostConfig>
    </Connector>



When analysing the tomcats code, I have figured out this occurred after an improvement done to "Include failed TLS handshakes in the access log"[1]. 
But I could able to find out which causes the SSL engine to be null. 

[1] - https://github.com/apache/tomcat/commit/acf6076d7118571ebc881984b96792f861b72bb2
Comment 1 Remy Maucherat 2019-08-29 16:30:48 UTC
Avoiding the NPE worked well for me, so the fix will be in 9.0.25 and 8.5.46.
Comment 2 Mark Thomas 2019-09-06 13:25:28 UTC
*** Bug 63735 has been marked as a duplicate of this bug. ***
Comment 3 Mark Thomas 2019-09-06 14:47:31 UTC
*** Bug 63735 has been marked as a duplicate of this bug. ***