Bug 63735

Summary: org.apache.coyote.AbstractProtocol$ConnectionHandler.process Error reading request, ignored java.lang.NullPointerException at org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.getSslSupport(NioEndpoint.java:1349) at org.apache.coyote.AbstractProtoco
Product: Tomcat 8 Reporter: Ranita <user.ranita>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P2    
Version: 8.5.45   
Target Milestone: ----   
Hardware: All   
OS: Linux   

Description Ranita 2019-09-06 13:04:58 UTC
HI Team,

We have recently upgraded our tomcat from 8.5.43 to 8.5.45 version. Post upgrade we are seeing below error message in catalina.out repeatedly.


org.apache.coyote.AbstractProtocol$ConnectionHandler.process Error reading request, ignored
java.lang.NullPointerException
at org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.getSslSupport(NioEndpoint.java:1349)
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:775)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1425)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at org.apache.tomcat.util.net.AbstractEndpoint.processSocket(AbstractEndpoint.java:830)
at org.apache.tomcat.util.net.NioEndpoint$Poller.add(NioEndpoint.java:669)
at org.apache.tomcat.util.net.NioEndpoint$NioSocketWrapper.registerReadInterest(NioEndpoint.java:1264)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1433)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:745)



Out connector configuration for https port 7443 is as below:

< Connector port="7443" protocol="org.apache.coyote.http11.Http11NioProtocol" SSSLEnabled="true" keystoreFile="/../../../xx.jks" maxtreads = "1200" scheme="https" secure="true" clientAuth="false" sslProtocol = "TLS" ..../>

We haven't face this issue any earlier version so far. Kindly help us on this.

~Ranita M
Comment 1 Mark Thomas 2019-09-06 13:25:28 UTC

*** This bug has been marked as a duplicate of bug 63706 ***
Comment 2 Ranita 2019-09-06 14:37:34 UTC
Thanks for replying.

Is the solution is to upgrade to version 8.5.46 ??

Is 8.5.46 available now?
Comment 3 Mark Thomas 2019-09-06 14:47:31 UTC

*** This bug has been marked as a duplicate of bug 63706 ***
Comment 4 Mark Thomas 2019-09-06 14:48:43 UTC
(In reply to Ranita from comment #2)
> Thanks for replying.
> 
> Is the solution is to upgrade to version 8.5.46 ??

Yes.

> Is 8.5.46 available now?

No. The release process will probably start next week.