Bug 64315

Summary: configure output for OpenSSL wrong/incomplete sometimes
Product: Tomcat Native Reporter: Michael Osipov <michaelo>
Component: LibraryAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 1.2.23   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Michael Osipov 2020-04-06 12:19:54 UTC
When OpenSSL lives in /usr then configure output will be:
> checking for OpenSSL library... using openssl from /usr/ and /usr/include

'/usr/' is obviously wrong. The root cause is in build/tcnative.m4. In the case of '"$use_openssl" = "/usr"' 'test -d $use_openssl/lib64 && ssllibdir=lib64 || ssllibdir=lib" is not executed', thus remains unset.

The simplest fix is to move the dir test out of the if clause.
Comment 1 Michael Osipov 2020-04-06 14:12:52 UTC
More over, the ssllibdir is always wrong on HP-UX. It has to be either lib/hpux32 or lib/hpux64.
Comment 2 Michael Osipov 2020-04-06 20:36:11 UTC
Fix in 1.2.24 and onwards