Bug 64475

Summary: Menu Generate HTML Report: When report generation fails due to timeout, error message is not explicit
Product: JMeter Reporter: Iliya Iliev <iliya.iliev88>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: enhancement CC: iliya.iliev88, p.mouawad
Priority: P2 Keywords: FixedInTrunk
Version: 5.3   
Target Milestone: JMETER_5.4   
Hardware: All   
OS: All   

Description Iliya Iliev 2020-05-28 04:21:04 UTC
Report is not generated neither from cli nor via UI when .jtl files is passed

Generating report
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.thoughtworks.xstream.core.util.Fields (file:/C:/apache-jmeter-5.3/apache-jmeter-5.3/lib/xstream-1.4.11.1.jar) to field java.util.TreeMap.comparator
WARNING: Please consider reporting this to the maintainers of com.thoughtworks.xstream.core.util.Fields
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

p.s. .jtl all file is above  2gb
Comment 1 Felix Schumacher 2020-05-28 14:10:41 UTC
Would you be able to share your file? I don't think it would be a good idea to attach it here, though.

*** This bug has been marked as a duplicate of bug 64455 ***
Comment 2 Felix Schumacher 2020-06-03 14:19:56 UTC
This bug seems to be not a duplicate of 64455, but more a configuration/UX problem.

The generating of the report takes longer than the default command timeout (property generate_report_ui.generation_timeout), which is 120000 ms.

The message that gets displayed shows irrelevant warnings, but doesn't show any hint on the timed out operation. The user has to look at the log window (toggle visibility on the top right corner of the main window). And while there is a log message about the timeout, there is no hint on how to extend the period.

So all in all, the UX can be enhanced :)