Bug 65440

Summary: jmeter 5 cannot use key store with http sample while jmeter 4 can
Product: JMeter Reporter: leiyang <675686066>
Component: HTTPAssignee: JMeter issues mailing list <issues>
Status: NEEDINFO ---    
Severity: normal    
Priority: P2    
Version: 5.4.1   
Target Milestone: JMETER_5.5   
Hardware: PC   
OS: All   
Attachments: jmeter4, working
jmeter 5, not working

Description leiyang 2021-07-08 01:46:26 UTC
Created attachment 37947 [details]
jmeter4, working

I want to send https request with client certificate.
 
I use key store configuraton with my pkcs12 key.

In jmeter 5.4.1 with jdk 11, i can see in the log key successfully loaded, but https request does not use the key at all.

I tried same steps and configurations in jmeter 4.0,it worked.

I've attached both jmeter version plans.

I have posted all detailed information in stackoverflow question:

https://stackoverflow.com/questions/68288877/jmeter-5-set-client-tls-certificate-not-work
Comment 1 leiyang 2021-07-08 01:48:26 UTC
Created attachment 37948 [details]
jmeter 5, not working
Comment 2 Felix Schumacher 2021-08-23 11:25:14 UTC
Have you tried the old plan with a newer JMeter (but with old Java 8)?

Can you post jmeter.log files for the two runs? Maybe even with more logging enabled for http traffic and keystore logic?

Are you sure, that that you are using the same keystore for both runs? Can you post a listing of the keystore?