Bug 7619

Summary: TLV incorrectly flagging error of <fmt-rt:param> tag is nested inside a <fmt:message> tag.
Product: Taglibs Reporter: Ryan Lubke <Ryan.Lubke>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: major CC: sabreware
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Ryan Lubke 2002-03-29 20:30:38 UTC
Given:

  <fmt:message key="pkey">
      <fmt-rt:param value="value1"/>
      <fmt-rt:param value="value2"/>
  <fmt:message>

Result:
  Validation error messages from tag library fmt-rt
  null: <param> outside <message>
  null: <param> outside <message>

NOTE:  If this is reversed where the message tag is from the RT library
       and the param tags are from the EL, the TLV will produce the same
       error.
Comment 1 Shawn Bayern 2002-03-31 22:48:26 UTC
*** Bug 7645 has been marked as a duplicate of this bug. ***