Bug 7645

Summary: <fmt-rt:param> Validation Error
Product: Taglibs Reporter: David Geary <sabreware>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description David Geary 2002-03-31 20:32:11 UTC
I have this code:

<fmt:message key='message.diskFull'>
   <fmt:param value='${5}'/>
   <fmt-rt:param value='<%= new java.util.Date() %>'/> 
</fmt:message>

My properties file looks like this:

message.diskFull=Disk number <b>{0}</b> filled up at <b>{1, time}</b> on <b>
{1, date}</b>.

I get the following error message:

<h3>Validation error messages from tag library fmt-rt</h3><p>null: 
&lt;param&gt; outside &lt;message&gt;</p>

It looks to me like the <param> tag is in the <message> tag, but I've been 
wrong before. ;-)
Comment 1 Shawn Bayern 2002-03-31 22:48:25 UTC
No, you're right.  This time, however, it's just a duplicate bug.  :-)

Jan has fixed it temporarily by removing the validation logic.

*** This bug has been marked as a duplicate of 7619 ***