Bug 7795

Summary: Support XHTML media type (RFC 3236) in default install
Product: Apache httpd-2 Reporter: Dave Hodder <dmh>
Component: mod_mimeAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED FIXED    
Severity: normal    
Priority: P3    
Version: 2.0.35   
Target Milestone: ---   
Hardware: All   
OS: All   
Attachments: Test XHTML file (index.xhtml)

Description Dave Hodder 2002-04-06 16:16:14 UTC
Would it be possible for someone to add support for RFC 3236 (the
'application/xhtml+xml' media type registration) into the default Apache
server installation?  It's missing in both version 1.3.x and 2.0.x.

Firstly, the registration should appear inside the mime.types file:

    application/xhtml+xml		xhtml xht

Secondly the DirectoryIndex directive inside httpd.conf (or all the
http*.conf* files) should have a reference to 'index.xhtml', e.g.:

    DirectoryIndex index.xhtml index.html

... or perhaps:

    DirectoryIndex index.xhtml index.html index.xhtml.var index.html.var

Many thanks,

Dave
Comment 1 Joshua Slive 2002-04-06 18:59:17 UTC
*** Bug 7796 has been marked as a duplicate of this bug. ***
Comment 2 Dave Hodder 2002-04-13 15:45:22 UTC
Created attachment 1542 [details]
Test XHTML file (index.xhtml)
Comment 3 Joshua Slive 2002-04-14 16:45:18 UTC
I've added the type to mime.types, but I'm not going to change the default
DirectoryIndex.  I see no reason to do that unless we see this type becoming
the predominant default type.  For now, people can edit their own config
files, just like they do for php, etc.

Thanks for using Apache!