Bug 8335

Summary: NPE if parseLocale attribute of <fmt_rt:parseNumber> is provided a null value.
Product: Taglibs Reporter: Ryan Lubke <Ryan.Lubke>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: major    
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Ryan Lubke 2002-04-21 00:37:29 UTC
Given:

<fmt:parseNumber value="1234" parseLocale='<%= null %>'

Result:

java.lang.NullPointerException
     [java] 	at
org.apache.taglibs.standard.tag.common.fmt.SetLocaleSupport.parseLocale(SetLocaleSupport.java:184)
     [java] 	at
org.apache.taglibs.standard.tag.common.fmt.SetLocaleSupport.parseLocale(SetLocaleSupport.java:156)
     [java] 	at
org.apache.taglibs.standard.tag.rt.fmt.ParseNumberTag.setParseLocale(ParseNumberTag.java:96)
Comment 1 Ryan Lubke 2002-04-21 01:41:22 UTC
parseDate suffers from the same issue.

Stacktrace:

[java] 	at
org.apache.taglibs.standard.tag.common.fmt.SetLocaleSupport.parseLocale(SetLocaleSupport.java:184)
     [java] 	at
org.apache.taglibs.standard.tag.common.fmt.SetLocaleSupport.parseLocale(SetLocaleSupport.java:156)
     [java] 	at
org.apache.taglibs.standard.tag.rt.fmt.ParseNumberTag.setParseLocale(ParseNumberTag.java:96)
Comment 2 Jan Luehe 2002-04-23 21:10:46 UTC
*** Bug 8427 has been marked as a duplicate of this bug. ***
Comment 3 Jan Luehe 2002-04-24 17:58:43 UTC
Fixed.