Bug 8591

Summary: Build problem - JARs contain package.html files
Product: POI Reporter: Drew Varner <drew.varner>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: minor CC: glens
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: other   

Description Drew Varner 2002-04-27 19:47:34 UTC
The JARs created by the build process include the package.html files from the 
source.

The problem is in xbuild.xml in the JAR centipede.cents.jar.

The filesets look like this ...

      <fileset dir="${xlayout.build.classes.dir}">
        <include name="**"/>
      </fileset>

and the should look like this ...

      <fileset dir="${xlayout.build.classes.dir}">
        <include name="**"/>
        <exclude name="**/package.html"/>
     </fileset>

I think excluding only package.html is better than excluding *.html

The patch looks something like this

179a180
>         <exclude name="**/package.html"/>
196a198
>         <exclude name="**/package.html"/>
213a216
>         <exclude name="**/package.html"/>
230a234
>         <exclude name="**/package.html"/>
Comment 1 Nicola Ken Barozzi 2002-04-27 20:01:39 UTC
This is a delicate point...

IMHO or I exclude all files which are not classes, or I include them all.
There needs to be consistent behaviour.

Developers are used to have the possibility of including resources in the jar, 
so I tend to include...

Any thoughts on this?
Comment 2 Andy Oliver 2002-04-27 21:41:14 UTC
should be okay for POI I think except obviously doc build type things... I mean
we're not ever going to do something (that I can imagine) that would require
html files.
Comment 3 Drew Varner 2002-04-27 22:04:41 UTC
I think we should exclude **/package.html explicitly.

> IMHO or I exclude all files which are not classes

There are situations where we want to include HTML as a resource.
We don't want to limit the JAR to just *.class files because we need to include 
*.properties, *.xml, *.png, etc.

> or I include them all

I think package.html doesn't belong in the JARs. **/package.html doesn't stop 
useful html. Maybe a comment ought to indicate what the exclude is for, though 
it seems self-evident.
Comment 4 Nicola Ken Barozzi 2002-04-28 12:49:57 UTC
Fixed it in my local copy and will be available in the next centipede.cent.jar 
commit.

Please Check after that if it's working ok, and in case mark this ug as 
verified.

Thank you :-)
Comment 5 Andy Oliver 2002-05-20 21:05:41 UTC
glen please read comments -- didn't mean to close
Comment 6 Andy Oliver 2002-05-20 21:06:14 UTC
oopps wrong bug
Comment 7 Rainer Klute 2002-12-13 14:59:57 UTC
I think this bug can be closed, can't it? 
Comment 8 Rainer Klute 2002-12-30 15:48:45 UTC
Seems that this is no problem anymore.