Bug 9218

Summary: Variable declared with an application scope is accessible with EL without specifying the scope
Product: Taglibs Reporter: Prasad Subramanian <prasad.subramanian>
Component: Standard TaglibAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED INVALID    
Severity: normal    
Priority: P3    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: other   

Description Prasad Subramanian 2002-05-18 03:05:00 UTC
If a variable say "foo " is decalred to be in application scope then an 
expression ${foo} returns  the value.
Ideally it should be "${applicationScope.foo}"
This would in conformation with pageContext.getAttribute("var" ,Scope)
Comment 1 Shawn Bayern 2002-05-18 05:07:41 UTC
Not a bug; this is specified behavior.  See section A.5:  "The EL evaluates an 
identifier by looking up its value as an attribute, according to
the behavior of PageContext.findAttribute(String)."