Bug 10213 - HSSF corrupts Excel file with VBA code in it
Summary: HSSF corrupts Excel file with VBA code in it
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-dev
Hardware: All All
: P3 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 6882 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-06-25 14:20 UTC by Craig Esterhuizen
Modified: 2004-11-16 19:05 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Esterhuizen 2002-06-25 14:20:18 UTC
If I have read and written to an Excel 2000 file originally containing VBA code 
with the Jakarta API, Excel 2000 can no longer open it as it has probably 
become corrupted.  On opening the file again with Excel, an Excel error 
results.  This happens every time.  I am not sure if your API is meant for 
Excel 2000 files but this is the Office version we have here...
We are using jakarta-poi-1.5.0-dev-20020416-bin.zip
We *really* need this fixed, please.

Regards
Craig
Comment 1 Avik Sengupta 2002-06-26 04:25:22 UTC
This is not yet supported. I agree this is an important feature, but no one
seems to have the bandwith to take care of it immediately. Care to submit a fix?
Andy has provided some ideas on how to do this many times on the dev list. 
Comment 2 Andy Oliver 2002-08-02 01:42:25 UTC
I'm on it.
Comment 3 Andy Oliver 2002-09-02 02:45:37 UTC
*** Bug 6882 has been marked as a duplicate of this bug. ***
Comment 4 Andy Oliver 2002-09-16 18:17:06 UTC
fixed.  Craig has confirmed as have a few others.  Thanks to Intec for funding
this project and SuperLink Software contributers Marc Johnson and Me.