Bug 11506 - Sample documents for HDF errors
Summary: Sample documents for HDF errors
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HDF (show other bugs)
Version: unspecified
Hardware: PC All
: P3 normal with 7 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 16305 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-08-06 17:50 UTC by Shef
Modified: 2009-11-19 21:16 UTC (History)
1 user (show)



Attachments
Sample ms word docs that cause errors (29.52 KB, application/octet-stream)
2002-08-06 17:51 UTC, Shef
Details
Another test doc (25.00 KB, application/octet-stream)
2003-10-21 11:04 UTC, Ryan Ackley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shef 2002-08-06 17:50:59 UTC
The attached zip file includes MS Word documents that cause errors when opened 
with the WordDocument class in HDF. Here are the stack traces:

The line numbers for WordDocument.java will be a bit off,
but the other line numbers should be accurate.

ASIANSRC.DOC:
java.io.IOException: Invalid header signature; read 290834161423197659, 
expected -2226271756974174256

	at org.apache.poi.poifs.storage.HeaderBlockReader.<init>
(HeaderBlockReader.java:124)

	at org.apache.poi.poifs.filesystem.POIFSFileSystem.<init>
(POIFSFileSystem.java:120)

	at org.apache.poi.hdf.extractor.WordDocument.<init>
(WordDocument.java:247)


ARG_TOT.DOC
java.io.FileNotFoundException: no such entry: "0Table"

	at org.apache.poi.poifs.filesystem.DirectoryNode.getEntry
(DirectoryNode.java:282)

	at org.apache.poi.hdf.extractor.WordDocument.processComplexFile
(WordDocument.java:335)

	at org.apache.poi.hdf.extractor.WordDocument.readFIB
(WordDocument.java:301)

	at org.apache.poi.hdf.extractor.WordDocument.<init>
(WordDocument.java:251)

	

DataDictionary.doc:
java.lang.ArrayIndexOutOfBoundsException

	at org.apache.poi.hdf.extractor.Utils.convertBytesToShort(Utils.java:83)

	at org.apache.poi.hdf.extractor.TC.convertBytesToTC(TC.java:86)

	at org.apache.poi.hdf.extractor.StyleSheet.doTAPOperation
(StyleSheet.java:1061)

	at org.apache.poi.hdf.extractor.StyleSheet.uncompressProperty
(StyleSheet.java:731)

	at org.apache.poi.hdf.extractor.StyleSheet.uncompressProperty
(StyleSheet.java:601)

	at org.apache.poi.hdf.extractor.WordDocument.createParagraph
(WordDocument.java:976)

	at org.apache.poi.hdf.extractor.WordDocument.addBlockContent
(WordDocument.java:930)

	at org.apache.poi.hdf.extractor.WordDocument.writeSection
(WordDocument.java:735)

	at org.apache.poi.hdf.extractor.WordDocument.<init>
(WordDocument.java:265)
Comment 1 Shef 2002-08-06 17:51:54 UTC
Created attachment 2604 [details]
Sample ms word docs that cause errors
Comment 2 Andy Oliver 2002-08-06 23:46:45 UTC
which version of word was this generated with?
Comment 3 Shef 2002-08-07 15:54:55 UTC
I'm not sure what the word version was; the files are dated 1993, 1996, & 1999. 
The 1999 one is almost certainly Word '97. Word '97 successfully opens the 
other two.
Comment 4 Andy Oliver 2002-08-07 19:14:18 UTC
cool.  Just FYI we don't plan to support pre-97 formats.  I really appreciate
the test cases!  Thanks.
Comment 5 Kevin Simons 2003-09-25 13:12:57 UTC
java.io.FileNotFoundException: no such entry: "0Table"
means it is stored as word 6.0/95 format

java.io.IOException: Invalid header signature; read 290834161423197659, 
expected -2226271756974174256
I had this once and I believe this happens when you save the word doc as 
word97/2002 & rtf instead of word document.

java.lang.ArrayIndexOutOfBoundsException
have no clue for this one but if you allready have let me know (because I also 
receive this one on a few

Besides those I also have the following exceptions in other documents:
java.lang.NegativeArraySizeException
java.lang.NullPointerException
Comment 6 Ryan Ackley 2003-09-25 13:28:09 UTC
ASIANSRC.DOC is not even an OLE document. Its POIFS throwing the exception not 
HDF.

ARG_TOT.DOC is a Word 6.0/95 document.

DataDictionary.doc's bug has been reported before but I think this is the first 
time someone has actually attached a document it will be fixed in the next 
release. NOTE: HDF has changed to HWPF
Comment 7 Ryan Ackley 2003-10-21 11:04:37 UTC
Created attachment 8648 [details]
Another test doc
Comment 8 Ryan Ackley 2003-10-21 11:05:31 UTC
*** Bug 16305 has been marked as a duplicate of this bug. ***
Comment 9 David Fisher 2009-11-19 21:16:29 UTC
According to records this was marked as a duplicate of 16305 years ago.