Bug 12670 - When setting the border of some cells the whole sheet is "bordered"
Summary: When setting the border of some cells the whole sheet is "bordered"
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: unspecified
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-16 07:57 UTC by Thorsten Kleinhenz
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Kleinhenz 2002-09-16 07:57:51 UTC
Hello,
I use POI in the last nightly version (1.8.0-dev-20020916) on a WinNT system 
and have a problem concerning borders:
I read a "table-border-structure" from a sheet, write some data into it, then I 
want to set a border around the cells I created using the "table-border-
structure" I've saved before. I print the no. of the row and the cell I' 
setting the border of and everything seems to be correct, but if I open my 
sheet in Excel every cell is bordered... instead of only the cells I bordered 
with POI.
I set the color and every side of the cell, if I change the color from black to 
blue e.g. the whole sheet is bordered with a blue border.
Can anyone reproduce this problem or even give me a solution??

Regards,
Thorsten
Comment 1 Andy Oliver 2003-07-24 13:25:50 UTC
This is more of a question for the list.  I suspect he grabed the cell styles
from existing cells and hence set the default border as well.