Bug 12768 - setting the cell color
Summary: setting the cell color
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-dev
Hardware: Other other
: P1 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-18 12:22 UTC by sridevi
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sridevi 2002-09-18 12:22:24 UTC
Hi,

  I am using jakarta-poi-1.8.0-dev-20020910.jar . I want to set the cell color 
red. But if I am doing so I am getting the value(content) of the cell as red 
color but not the entire cell red color. I am doing so using following code :

        HSSFCellStyle    cs     = hssfworkbook.createCellStyle();
        HSSFFont         f      = hssfworkbook.createFont();
        f.setColor(f.COLOR_RED);
        cs.setFont(f);
        cell.setCellStyle(cs);

   Is it that using POI we can't set the cell color(not the content of the 
cell) as red color.

    Will be very happy with your sooner reply.

Rgds,
sm
Comment 1 Andy Oliver 2002-09-19 14:14:36 UTC
This is a question not a bug, please ask it on the mail list.