Bug 13248 - [Patch] HSSF does not save user defined number formats
Summary: [Patch] HSSF does not save user defined number formats
Status: CLOSED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-dev
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 13617 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-10-03 15:23 UTC by Shawn Laubach
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments
Patch to add functionality to FormatRecord and test case to ensure it doesn't disappear (5.01 KB, patch)
2002-10-03 15:27 UTC, Shawn Laubach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Laubach 2002-10-03 15:23:08 UTC
FormatRecord code recently changed to handle unicode strings.  This change made 
it impossible for user defined strings to be set.  The following patch makes 
use of the supplied methods and adds some to use the unicode functionality.
Comment 1 Shawn Laubach 2002-10-03 15:27:05 UTC
Created attachment 3335 [details]
Patch to add functionality to FormatRecord and test case to ensure it doesn't disappear
Comment 2 Shawn Laubach 2002-10-04 21:56:34 UTC
Committed updates.
Comment 3 Shawn Laubach 2002-10-14 21:54:47 UTC
*** Bug 13617 has been marked as a duplicate of this bug. ***