Bug 13630 - Tag design is not spec compliant
Summary: Tag design is not spec compliant
Status: CLOSED DUPLICATE of bug 12508
Alias: None
Product: Taglibs
Classification: Unclassified
Component: I18N Taglib (show other bugs)
Version: 1.0
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-10-15 05:46 UTC by Mark Yang
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Yang 2002-10-15 05:46:11 UTC
When using i18n taglib with Tomcat 4.12(when tag pooling is enabled)
the release() will not be called on the tag instances when the tag get 
re-used, the i18n bundle tag seems work incorrectly.

Is the tag spec compliant? 

See http://jakarta.apache.org/taglibs/guidelines.html
See Tomcat bug 13392 "When tag pooling is enabled, release() is not called on 
tag instances" for more information.
Comment 1 Mark Yang 2002-10-15 09:58:45 UTC
It seems that bug is fixed at bug 12508
and not cause by not calling release() when tag pooling was enabled.
Comment 2 Mark Yang 2002-10-15 10:18:31 UTC
Sorry for all, 
I have patch the patch gived in bug 12508
but it does not work for me.
the problem is the same.

sorry for changing the Status to RESOLVED!
Comment 3 Mark Yang 2002-10-15 10:34:48 UTC

*** This bug has been marked as a duplicate of 12508 ***