Bug 14687 - XPath function position() not working on <x:out />
Summary: XPath function position() not working on <x:out />
Status: RESOLVED DUPLICATE of bug 14465
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: 1.0
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-19 17:20 UTC by Nils Kilden-Pedersen
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nils Kilden-Pedersen 2002-11-19 17:20:18 UTC
When looping an XPath expression using <x:forEach/>, the <x:out select="position
()"/> outputs only 0. A similar loop in XSLT using <xsl:for-each/> and 
<xsl:value-of select="position()"/> will correctly return the position.
This result is obtained on Tomcat 4.1.12-LE-jdk1.4 using JSTL 1.0.2 on Windows 
2000 with j2sdk1.4.1_01
Comment 1 Pierre Delisle 2002-12-04 01:11:45 UTC
The JSTL Expert Group will consider the issue for the JSTL 1.1 
Maintenance Release.

*** This bug has been marked as a duplicate of 14465 ***