Bug 15184 - getFirstCellNum() 0 based, getLastCellNum() 1 based
Summary: getFirstCellNum() 0 based, getLastCellNum() 1 based
Status: RESOLVED DUPLICATE of bug 14910
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 1.5.1
Hardware: PC All
: P3 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-12-09 16:44 UTC by Holger Schulz
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Schulz 2002-12-09 16:44:18 UTC
Hello!

For a sheet with data just in column "A" getFirstCellNum() returns 0, 
getLastCellNum() returns 1.
For a sheet with data just in column "B" getFirstCellNum() returns 1, 
getLastCellNum() returns 2.

I can't find a good reason why getLastCellNum() is 1 based.

Greetings from Germany

    Holger
Comment 1 Avik Sengupta 2002-12-12 12:58:12 UTC

*** This bug has been marked as a duplicate of 14910 ***