Bug 15400 - doTrace implementation cannot handle multiple header names
Summary: doTrace implementation cannot handle multiple header names
Status: RESOLVED WONTFIX
Alias: None
Product: Tomcat 4
Classification: Unclassified
Component: Servlet & JSP API (show other bugs)
Version: 4.1.12
Hardware: All All
: P3 normal with 1 vote (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-12-16 14:35 UTC by Stefan Eissing
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Eissing 2002-12-16 14:35:29 UTC
When sending a request with multiple defined headers like:

Some-Header: first
Some-Header: second
Some-Header: third, fourth

Only the first header line is echoed back in the response.
Comment 1 Mark Thomas 2004-02-27 20:25:28 UTC
The implementation of doTrace() is in javax.servlet.http.HttpServlet and is 
outside of the control of the tomcat team.

The problem is that the implementation uses getHeader() rather than getHeaders
()

If this is a problem for you, your best bet is to override the doTrace() 
method in your servlet. As a starter the javax.servlet.http.HttpServlet 
impementation is available from 
http://cvs.apache.org/viewcvs.cgi/*checkout*/jakarta-servletapi-
5/jsr154/src/share/javax/servlet/http/HttpServlet.java