Bug 16526 - RewriteEngine off still clashes with No FollowSymLinks
Summary: RewriteEngine off still clashes with No FollowSymLinks
Status: CLOSED DUPLICATE of bug 12395
Alias: None
Product: Apache httpd-1.3
Classification: Unclassified
Component: mod_rewrite (show other bugs)
Version: 1.3.26
Hardware: PC Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-29 02:21 UTC by Trevor Phillips
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trevor Phillips 2003-01-29 02:21:08 UTC
If I add to a <Directory> block the following line:
  RewriteEngine off
And also have:
  AllowOverride None
  Options None

Then any accesses under that directory give a forbidden error, with the
following message logged:
   Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that
RewriteRule directive is forbidden

Why put RewriteEngine off in the first place? Well, I'm trying to have it ON for
everything under a directory, but turn it OFF for a subdirectory under the main
directory...
Comment 1 André Malo 2003-01-29 02:32:56 UTC

*** This bug has been marked as a duplicate of 12395 ***