Bug 17227 - Links for sample XMLs are inaccurate
Summary: Links for sample XMLs are inaccurate
Status: RESOLVED DUPLICATE of bug 14551
Alias: None
Product: Log4j - Now in Jira
Classification: Unclassified
Component: Other (show other bugs)
Version: 1.2
Hardware: All other
: P3 normal
Target Milestone: ---
Assignee: log4j-dev
URL: file://jakarta-log4j-1.2.8/docs/api/o...
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-20 01:32 UTC by Doug Toland
Modified: 2005-07-28 12:42 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Toland 2003-02-20 01:32:27 UTC
Just downloaded the 1.2.8 distribution. This was also an issue with 1.2.7 On the 
javadoc page: 
file://localhost/C:/jakarta-log4j-1.2.8/docs/api/org/apache/log4j/xml/examples/p
ackage-summary.html the links for the sample xml docs point to: 
file://localhost/C:/jakarta-log4j-1.2.8/docs/api/org/apache/log4j/xml/doc-files/
sample1.xml.


The xml/doc-files directory does not seem to be included in the distribution.  
The files do exist in: 
\jakarta-log4j-1.2.8\src\java\org\apache\log4j\xml\examples.




What follows is the corrected html for 
\\jakarta-log4j-1.2.8\src\java\org\apache\log4j\xml\examples\package.html




<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">


<html> <head>


<title></title>


</head>


<body>


 


<p>Example usage of log4j with XML (including source code).




<p>This package's shows how log4j can be used with an XML


configuration file.




<p>See source code of <a


href="../doc-files/XMLSample.java">XMLSample.java</a> showing how to


configure with an XML file.  Sample XML files 


<a href="sample1.xml">sample1.xml</a>, 


<a href="sample2.xml">sample2.xml</a>, 


<a href="sample3.xml">sample3.xml</a>, 


<a href="sample4.xml">sample4.xml</a>, 


<a href="sample5.xml">sample5.xml</a> are provided.




<hr>


<address></address>


<!-- hhmts start -->


Last modified: Wed Apr 12 22:27:25 MDT 2000


<!-- hhmts end -->


</body> </html>
Comment 1 Markus Krogemann 2004-04-13 08:33:23 UTC
the xml-samples are not included in the download at all neither do they seem to
be presend in the online javadoc. The dtd also appears to be missing, so it
won't be found following this link:
http://logging.apache.org/log4j/docs/api/org/apache/log4j/xml/doc-files/log4j.dtd

This bug regport concners version 1.2.8
Comment 2 Mark Womack 2005-07-01 22:54:01 UTC
1.2.12 candidate

documentation issue.
Comment 3 Yoav Shapira 2005-07-28 20:42:08 UTC
I've fixed this on HEAD (for 1.3-alpha7) so the sample are correctly linked and
included in both the online and download distributions.
Comment 4 Yoav Shapira 2005-07-28 20:42:32 UTC

*** This bug has been marked as a duplicate of 14551 ***