Bug 17452 - ant shell script fails to quote directory
Summary: ant shell script fails to quote directory
Status: RESOLVED DUPLICATE of bug 9550
Alias: None
Product: Ant
Classification: Unclassified
Component: Wrapper scripts (show other bugs)
Version: 1.5.1
Hardware: PC Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-26 20:44 UTC by David Eccleston
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Eccleston 2003-02-26 20:44:59 UTC
If your application is in a directory with a space in it the following error occurs:

   [deccles@mummy My Project]$ ant clean
   /usr/local/bin/ant: cd: /export/home/deccles/My: No such file or directory
   Buildfile: build.xml does not exist!
   Build Failed

Changing line 70 to this fixes the problem:
   cd "$saveddir"
Comment 1 Conor MacNeill 2003-02-26 22:14:26 UTC

*** This bug has been marked as a duplicate of 9550 ***