Bug 17791 - on EBCDIC systems, data not read correctly
Summary: on EBCDIC systems, data not read correctly
Status: RESOLVED DUPLICATE of bug 18947
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.0-dev
Hardware: Other other
: P1 blocker (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-07 21:10 UTC by Elvira Gurevich
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments
older excel file (13.50 KB, application/octet-stream)
2003-03-07 21:11 UTC, Elvira Gurevich
Details
BiffViewer output from exlhead011.xls (58.56 KB, text/plain)
2003-03-07 21:14 UTC, Elvira Gurevich
Details
excel2000 file (13.50 KB, application/octet-stream)
2003-03-07 21:14 UTC, Elvira Gurevich
Details
BiffViewer output generated from spreadsheet2000.xls (57.14 KB, text/plain)
2003-03-07 21:15 UTC, Elvira Gurevich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elvira Gurevich 2003-03-07 21:10:26 UTC
processing excel files on OS390 Open Edition 2.10
We created the files on windows and ftp'ed them (binary) to the os390.
Then used java code to read it.

POI code is: jakarta-poi-1.11.0-dev-20030303.jar

It seems that for an excel file created by an excel2000, only the sheet names 
are read incorrectly, whereas for older excel files, the format is misread also.

excel files and biffviewer output attached.
Comment 1 Elvira Gurevich 2003-03-07 21:11:35 UTC
Created attachment 5217 [details]
older excel file
Comment 2 Elvira Gurevich 2003-03-07 21:14:03 UTC
Created attachment 5218 [details]
BiffViewer output from exlhead011.xls
Comment 3 Elvira Gurevich 2003-03-07 21:14:38 UTC
Created attachment 5219 [details]
excel2000 file
Comment 4 Elvira Gurevich 2003-03-07 21:15:31 UTC
Created attachment 5220 [details]
BiffViewer output generated from spreadsheet2000.xls
Comment 5 Toshiaki Kamoshida 2003-04-21 10:55:57 UTC
Sorry I didn't know this is already submitted...
The PATCH to fix this and the way to found problems easily submitted at Bug 
18947.Please check it.
Comment 6 Andy Oliver 2003-07-24 15:55:15 UTC

*** This bug has been marked as a duplicate of 18947 ***