Bug 18826 - rpm task doesn't work with recent versions of rpm
Summary: rpm task doesn't work with recent versions of rpm
Status: RESOLVED DUPLICATE of bug 14650
Alias: None
Product: Ant
Classification: Unclassified
Component: Optional Tasks (show other bugs)
Version: 1.5.2
Hardware: Other Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2003-04-08 17:54 UTC by Ville Skyttä
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments
Introduce a customizable rpm build command (3.43 KB, patch)
2003-04-08 17:56 UTC, Ville Skyttä
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ville Skyttä 2003-04-08 17:54:22 UTC
Recent versions of rpm don't use the "rpm" command any more for building
packages, the command to use is "rpmbuild".

I'll attach a patch that makes the executable configurable.  Note that I've made
"rpmbuild" the default, which may break scripts of some users of pretty old rpm
(< 4.0.2 IIRC).  Just change the default if you think this is not appropriate,
don't let it slow down the process of getting this patch applied.  Thanks :)
Comment 1 Ville Skyttä 2003-04-08 17:56:02 UTC
Created attachment 5711 [details]
Introduce a customizable rpm build command
Comment 2 Jesse 2003-04-08 17:59:54 UTC

*** This bug has been marked as a duplicate of 14650 ***