Bug 19054 - Problem during saving excel file with macros
Summary: Problem during saving excel file with macros
Status: RESOLVED DUPLICATE of bug 18155
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-dev
Hardware: PC All
: P3 normal with 2 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-16 07:10 UTC by Ramil Israfilov
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments
test source code (450 bytes, text/plain)
2003-04-16 07:11 UTC, Ramil Israfilov
Details
test excel file (40.00 KB, application/octet-stream)
2003-04-16 07:12 UTC, Ramil Israfilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ramil Israfilov 2003-04-16 07:10:58 UTC
After saving excel file with existing macros problem occurs.
There is no exception during saving, but if you open file in MSExcel 2000 there 
is an error: "File error: data may have been lost" and macros execution fails.
I used dev-10 release during tests. 
Source excel file and test source code attached to message
Comment 1 Ramil Israfilov 2003-04-16 07:11:49 UTC
Created attachment 5852 [details]
test source code
Comment 2 Ramil Israfilov 2003-04-16 07:12:06 UTC
Created attachment 5853 [details]
test excel file
Comment 3 Tony Nys 2003-04-29 08:09:36 UTC
This bugs look similar as bug 18155 
(excel error message is the same: 'file error:data may have been lost')
but the macro is a little different here, causing the same error
Comment 4 Andy Oliver 2003-07-24 16:13:12 UTC

*** This bug has been marked as a duplicate of 18155 ***