Bug 19477 - c:url, encoding
Summary: c:url, encoding
Status: RESOLVED DUPLICATE of bug 16912
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: unspecified
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-30 13:49 UTC by Tomas Zverina
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zverina 2003-04-30 13:49:16 UTC
class: org.apache.taglibs.standard.tag.common.core.ParamSupport
method: doEndTag()

This method uses deprecated URLEncoder.encode(value):

parent.addParameter(URLEncoder.encode(name), URLEncoder.encode(value));

which uses deafult system encoding, which can be different from page encoding.
This leads to incorrect encoding of URL string.
Comment 1 Pierre Delisle 2003-04-30 14:33:14 UTC

*** This bug has been marked as a duplicate of 16912 ***