Bug 19642 - how to hide gridlines on an excel sheet
Summary: how to hide gridlines on an excel sheet
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: unspecified
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 21872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-05-05 09:16 UTC by arshi singh
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arshi singh 2003-05-05 09:16:02 UTC
Hi,
    I have been using the     apache.poi.hssf package for my project. I have
made an excel sheet using HSSFSheet class in org.apache.poi.hssf.usermodel
package. This class has 2 member functions for setting properties of
gridlines on the sheet.
    void setGridsPrinted(boolean value) 
    void setPrintGridlines(boolean newPrintGridlines)
I tried to hide the gridlines using both these functions but they are not
working. Where am i going wrong?  The exact code is given below.
 
import org.apache.poi.poifs.filesystem.POIFSFileSystem;
import org.apache.poi.hssf.usermodel.*;
import org.apache.poi.hssf.util.*;
 
static HSSFWorkbook wb;
static HSSFSheet sheet;
static HSSFRow sheet_row;
.....
{ ....
FileReader fr= new FileReader("Daily1.txt");
 BufferedReader br = new BufferedReader(fr);
 String sheetName="Daily";
 String fileName ="out.xls";
 FileOutputStream fileOut = new FileOutputStream(fileName);
 
 wb = new HSSFWorkbook();
 sheet = wb.createSheet(sheetName);
 sheet.setGridsPrinted(false);
 sheet.setPrintGridlines(false);
....
....
wb.write(fileOut);
 fileOut.close();
 fr.close();
 
Kindly help me find the problem.
Comment 1 Andy Oliver 2003-07-24 16:29:54 UTC
Ask questions on the mail list, post bugs in bugzilla.
Comment 2 arshi singh 2003-07-25 04:30:22 UTC
*** Bug 21872 has been marked as a duplicate of this bug. ***