Bug 19846 - logrotates failed unexpectedly
Summary: logrotates failed unexpectedly
Status: CLOSED DUPLICATE of bug 24805
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.0.45
Hardware: All Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-12 09:39 UTC by Terence Chan
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terence Chan 2003-05-12 09:39:17 UTC
When I shutdown apache - the logrotate on one of the logs (I have two logs - 
one for access and one for error)failed unexpectedly and leaving a child behind.

I checked and see the child id has changed before and after shutdown - 
therefore, I suspected the child has restarted itself after the apachectl stop 
command has issued.

[Mon May 12 17:11:32 2003] [notice] Apache/2.0.45 (Unix) mod_ssl/2.0.45 
OpenSSL/0.9.7b configured -- resuming normal operations
piped log 
program ' /usr/local/apache/bin/rotatelogs /home/www/bb03.startv.com/logs/access
_log 21600' failed unexpectedly
[Mon May 12 17:11:42 2003] [notice] caught SIGTERM, shutting down
Comment 1 Jeff Trawick 2003-12-14 01:22:14 UTC
problem now fixed in 2.1-dev

thanks for your report!


*** This bug has been marked as a duplicate of 24805 ***