Bug 19993 - "child pid 25109 exit signal Bus error (10)" occuring with mod_auth_ldap
Summary: "child pid 25109 exit signal Bus error (10)" occuring with mod_auth_ldap
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_authn_ldap (show other bugs)
Version: 2.0.45
Hardware: Sun Solaris
: P3 blocker (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-16 17:35 UTC by jemiller
Modified: 2015-05-11 02:01 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jemiller 2003-05-16 17:35:17 UTC
I have LDAP authentication working fine with version 2.0.44, but, I can't get 
2.0.45 to work. I think a new bug may have been introduced in mod_auth_ldap as 
I can see by reading the change log that some changes have been made to it.

The first error that I see in error_log is,

[Thu May 15 18:33:50 2003] [debug] util_ldap.c(1104): [25108] ldap cache init: 
Error 0

Then, when I try to authenticate, I receive the following error everytime I 
attempt to authenticate.

[Thu May 15 18:34:39 2003] [notice] child pid 25109 exit signal Bus error (10)

I have the following at the bottom of my httpd.conf file.

LDAPTrustedCA /opt/pkgs/httpd/conf/ssl.crt/ca-bundle.crt
LDAPTrustedCAType BASE64_FILE

<Directory /opt/pkgs/httpd-2.0.45/htdocs>
    AuthType Basic
    AuthName "Test"
    AuthLDAPURL ldap://myldapserver:389/ou=myou,dc=mydc,dc=mydc?uid?sub?(uid=*)
#    AuthLDAPStartTLS on
    require valid-user
</Directory>

Note, I've tried it without using TLS, and the same error occurs.

I'm using OpenLDAP 2.1.11 and OpenSSL 0.9.7.b.

I've checked the LDAP logs, and mod_auth_ldap never actually queries the LDAP 
server.
Comment 1 Erik Abele 2003-05-16 18:00:06 UTC

*** This bug has been marked as a duplicate of 18756 ***