Bug 20038 - This is a serious issue for me
Summary: This is a serious issue for me
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 1.5.1
Hardware: Other All
: P3 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-19 15:17 UTC by naresh
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naresh 2003-05-19 15:17:15 UTC
i am using  the jakarta-poi-1.5.1-final-bin.zip file containing the jar for POI.
i am facing problem when i try to send the created excel file through  mail as 
attachement.The excel file is created dynamically through POI

After the user received the mail he cannot able to view the excel file directly 
from the mail message.

Whe he clicks the view button on the excel sheet a error box appears sayng 
address refrence problem  "memory could not be read" and closes the Lotus mail 
client 

But with jakarta-poi-1.10.0-dev-bin.zip file it displaying a message box saying 
"Viewer could not be intialised "

We are using Lotus mail server.

I don't know whether this is a bug or i am not aware of the late FIXES 
available.

It will be helpfull for me if someone gives suggestion
Comment 1 Danny Mui 2003-05-19 15:24:48 UTC
try the mailing list, as long as the binary file can be viewed when generated,
it is only an attachment
Comment 2 naresh 2003-05-19 16:28:32 UTC
Is there any way to solove this porblem or any patch is available for that
Comment 3 Danny Mui 2003-05-19 20:11:07 UTC
"Viewer could not be intialised "

that means it's a client-side issue (notes/domino).  it sounds like the client
machine is hosed since it can't open Excel.  if the poi-generated excel binary
is generated correctly (it opens elsewhere) then you need to look elsewhere for
your solution. 
Comment 4 naresh 2003-05-20 04:58:57 UTC
The Lotus client is openeing the excel file correctly if the excel file is 
created using EXCEL Application.

Its giving problem only through POI

The excel file which i tested is generated from the HSSF.java file which is 
shipped with POI release.

i hope u understands
Comment 5 Andy Oliver 2003-05-20 14:09:50 UTC
Danny, he's talking about hte lotus office suite and or viewer that comes with notes.  For 
some reason it must be more picky than excel about something we are or are not doing.  
This is probably a valid bug, though since I don't have lotus, don't test on lotus and am 
not likely to do so (none of my clients use lotus presently) I doubt this will get fixed quickly 
without a lotus-enabled person to debug it.  I see a lot of IBMers coming in, maybe they'll 
sort it out.  Its probably very minor, just its pretty major to fix if you don't have lotus :-).  
Lets leave this one open.
Comment 6 Danny Mui 2003-05-20 14:19:29 UTC
I just attached 3 different poi-generated worksheets a draft email in
Notes/Domino 5.0x and used the internal viewer to display it.  They spanned from
the simple testcases from people in Bugzilla and to a complicated report I use
for work.  These cases I have seem to work.

Please attach the excel file you're using as I cannot reproduce your problem.
Comment 7 naresh 2003-05-22 12:35:23 UTC
Thanks for the replying
(Danny Mui and Andy)

I tried with the release of poi-bin-2.0-pre1-20030517 and its working well in 
the Lotus Client for Mail.

Is there any way to write the HTML contents directly into the  EXCEL file 
through POI
Because we are getting data in the Html Formatted String and its becoming 
difficult to get the format in excel



Comment 8 Danny Mui 2003-05-23 00:35:01 UTC
Since upgrading seems to have fixed this issue, I am marking this bug resolved.
 Ask that question to the mailing list, bugzilla is not the place for it.