Bug 20674 - Tomcat is not compliant with the JSP 1.2 specification.
Summary: Tomcat is not compliant with the JSP 1.2 specification.
Status: RESOLVED WORKSFORME
Alias: None
Product: Tomcat 4
Classification: Unclassified
Component: Jasper 2 (show other bugs)
Version: 4.1.24
Hardware: All Windows XP
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL: http://none.right.now
Keywords: ErrorMessage
: 20675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-11 09:00 UTC by kifoza
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kifoza 2003-06-11 09:00:18 UTC
Hello,

As:
http://java.sun.com/products/jsp/syntax/1.2/syntaxref1210.html#15653
says:
The page directive applies to an entire JSP page and any of its static include 
files, which together are called a translation unit. A static include file is a 
file whose content becomes part of the calling JSP page. The page directive does 
not apply to any dynamic resources; see <jsp:include> for more information. 

Yet, if we have page a.jsp and page b.jsp, a.jsp being:
----- begin a.jsp
<%@ page pageEncoding="ISO-8859-2" contentType="text/html;charset=ISO-8859-2"%>
<%@ include file="b.jsp"  %>
<some native chars (iso-8859-2)>
---- end a.jsp

and b.jsp being:
---- begin b.jsp
<some native chars (iso-8859-2)>
---- end b.jsp

The native chars in b.jsp ARE NOT displayed correctly (only the ones in a.jsp 
are displayed correctly).

I hope this is fixed once and for all in an upcoming tomcat release, please 
notify me of the fix.
Comment 1 Eric Carmichael 2003-08-09 05:58:57 UTC
*** Bug 20675 has been marked as a duplicate of this bug. ***
Comment 2 thanuj kumar 2003-08-18 11:18:54 UTC
There is problem in running the Jsp Tag files after removing the JSPC generated 
servlet-mappings and directly accessing the JSP file in Tomcat5.0.7

java.lang.IllegalArgumentException: -52
	org.apache.jasper.compiler.SmapStratum$LineInfo.setOutputLineIncrement
(SmapStratum.java:124)
Comment 3 Eric Carmichael 2003-08-18 14:12:19 UTC
IllegalArgumentException in setOutputLineIncrement() is Bugzilla Bug 22277, 
and is fixed in CVS.  Also I'm resetting the field values for this bug report 
to their previous values, as Bugzilla Bug 22277 is not related to this one.
Comment 4 Mark Thomas 2004-05-17 20:35:20 UTC
This works for me with the latest version of TC4 from CVS.