Bug 20871 - [RFE] Lie to excel. version issue while saving/updating an excel 2002 file
Summary: [RFE] Lie to excel. version issue while saving/updating an excel 2002 file
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.0-dev
Hardware: PC All
: P3 major with 1 vote (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-18 14:19 UTC by Mahesh Vannavada
Modified: 2009-02-18 09:23 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mahesh Vannavada 2003-06-18 14:19:05 UTC
When you create a new excel file using HSSF and open it with Excel 2002, excel 
prompts that the current excel file is saved using an older version and whether 
the user wants to save it in the older format. I was under the impression that 
the current version of the API supports excel 2002.

The problem becomes more acute in the situation when one is updating (adding 
rows or changing cell values or format) an existing excel 2002 file.
Comment 1 Andy Oliver 2003-07-24 16:53:28 UTC
in 3.0 we need to tell excel what it wants to hear maybe.  For users who want
the sheet to say "Yes I'm 2000 or XP format" it should.
Comment 2 Michael Zalewski 2003-08-07 00:18:27 UTC
FWIW: This does not seem to happen in all cases. I tried running 
org.apache.poi.hssf.usermodel.examples.CreateCells (which produces a simple 
workbook.xls). I could open the output file in both 2000 and XP (SR-1) without 
seeing this problem.

However, I did notice that POI/HSSF does not put the 'Storage Class ID' into 
the .xls file when it creates a new workbook from scratch. I thought this might 
be the cause of the problem, but upon further investigation I discovered that 
the class ID {00020820-0000-0000-C000-000000000046} is put for all versions of 
Excel. HSSF just puts in all zeros.

Also, there is a BOF record in the workbook, which has a field 
named 'rversion'. Excel 97 and Excel 2000 put 06100000. Excel XP puts 06200000. 
HSSF puts 06100000 (same as Excel 97). But that does not seem to make a 
difference when Excel XP opens the file.
Comment 3 Yegor Kozlov 2008-12-16 09:56:17 UTC
Please try the latest POI-3.5-beta4. I believe the problem is fixed. Both Excel 2003 and 2003 open files generated by POI without warnings.

Yegor
Comment 4 David Fisher 2009-02-18 09:23:47 UTC
No further information has been provided.