Bug 21305 - Excel crashing when reading large files generated by POI
Summary: Excel crashing when reading large files generated by POI
Status: RESOLVED DUPLICATE of bug 15375
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-pre3
Hardware: Other All
: P1 blocker with 4 votes (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-03 11:19 UTC by Julian Jones
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments
A sample Excel file generated by POI that will crash Excel when it tries to load it (347.21 KB, application/octet-stream)
2003-07-03 11:21 UTC, Julian Jones
Details
POITest.java (1.99 KB, text/plain)
2003-08-12 09:42 UTC, Gerhard Ruckriegel
Details
POITest.java with rows 0-821 creates files not loadable with Excel 2000 (9.0.3821 SR-1) (1.99 KB, text/plain)
2003-08-12 10:53 UTC, Gerhard Ruckriegel
Details
output Excel file generated from POITest (245.50 KB, application/octet-stream)
2003-08-13 13:13 UTC, Gerhard Ruckriegel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Jones 2003-07-03 11:19:49 UTC
Our server-side application uses POI 1.5.1 to generate Excel files, 
which are then streamed over HTTP to the browser. Generally this process
works fine, but some streamed files cause Excel to crash. The crash does
not appear to be version-specific (we see the same results in Excel 97 and
Excel XP). The Excel document generated always has 2 worksheets. We see
the crash typically when there are > 300 rows and > 150 columns in one of
the worksheets. I have read bug reports that Excel will crash if > 256
columns are used, but this is not the case for our worksheets.
All our cell values are written as Strings. We don't use formulas or any other
of the more sophisticated Excel facilities.
I will attach an example file that exhibits this problem.
Comment 1 Julian Jones 2003-07-03 11:21:56 UTC
Created attachment 7079 [details]
A sample Excel file generated by POI that will crash Excel when it tries to load it
Comment 2 Danny Mui 2003-07-03 14:35:26 UTC
Have you attempted to use 2.0pre?  1.5 is quite old.
Comment 3 Andy Oliver 2003-07-03 15:40:38 UTC
I suspect this is fixed in the 2.0-pre2 as soon as its released.  We're nearing release of 
2.0 and so all bug fixes are going into that release.
Comment 4 Andy Oliver 2003-07-24 17:02:08 UTC
information asked for but not given.
Comment 5 Gerhard Ruckriegel 2003-08-11 16:02:09 UTC
Even with 2.0-pre3 files larger than 1MB crash with Excel.
Comment 6 Andy Oliver 2003-08-11 16:21:07 UTC
please attach the minimum simplest amount of code necessary to reproduce it with a main (or as a 
junit test case, better yet).  It's not the file size, I generate files >1mb all the time.  File size is the 
most frequent red herring.  Certain bugs or conditions just happen mroe in big files.
Comment 7 Gerhard Ruckriegel 2003-08-12 09:42:35 UTC
Created attachment 7768 [details]
POITest.java
Comment 8 Gerhard Ruckriegel 2003-08-12 10:53:51 UTC
Created attachment 7769 [details]
POITest.java with rows 0-821 creates files not loadable with Excel 2000 (9.0.3821 SR-1)
Comment 9 Gerhard Ruckriegel 2003-08-13 13:12:25 UTC
the only workaround is to load the Excel file with Open Office and to save it 
again.

But still that's not sufficient.
Comment 10 Gerhard Ruckriegel 2003-08-13 13:13:53 UTC
Created attachment 7801 [details]
output Excel file generated from POITest
Comment 11 Avik Sengupta 2003-10-30 19:01:00 UTC
tested the code attached with latest CVS,  and the file opens perfectly in Excel XP

*** This bug has been marked as a duplicate of 15375 ***