Bug 21376 - Memory increase with HTTPS access
Summary: Memory increase with HTTPS access
Status: RESOLVED DUPLICATE of bug 25667
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.0.47
Hardware: PC All
: P3 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-07 16:14 UTC by Jos
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jos 2003-07-07 16:14:33 UTC
We have found that, running Apache 2.0.45 with mod_ssl and openssl 0.9.7b, 
memory used by the Apache2 process in W2000 SP 3 increases without an apparent 
limit.

We are using a robot that requests the same page on a continuos basis, an 
memory inrease is lineal from 8MB at startup (aprox) to 150MB after less than 
30 minutes.

This is an extract of time versus memory. At 17:51:50, the robot was stopped, 
and memory usage stabilized, but never decreased:


"07/07/2003 17:43:50.258","120725504"
"07/07/2003 17:44:05.258","122003456"
"07/07/2003 17:44:20.259","123035648"
"07/07/2003 17:44:35.259","124579840"
"07/07/2003 17:44:50.260","125636608"
"07/07/2003 17:45:05.260","127033344"
"07/07/2003 17:45:20.261","127873024"
"07/07/2003 17:45:35.261","129028096"
"07/07/2003 17:45:50.262","130412544"
"07/07/2003 17:46:05.262","131440640"
"07/07/2003 17:46:20.263","132747264"
"07/07/2003 17:46:35.263","134086656"
"07/07/2003 17:46:50.264","135081984"
"07/07/2003 17:47:05.264","136622080"
"07/07/2003 17:47:20.265","137715712"
"07/07/2003 17:47:35.265","138969088"
"07/07/2003 17:47:50.265","140304384"
"07/07/2003 17:48:05.266","141279232"
"07/07/2003 17:48:20.266","142516224"
"07/07/2003 17:48:35.267","143818752"
"07/07/2003 17:48:50.267","144842752"
"07/07/2003 17:49:05.268","145903616"
"07/07/2003 17:49:20.268","147378176"
"07/07/2003 17:49:35.269","148434944"
"07/07/2003 17:49:50.269","149663744"
"07/07/2003 17:50:05.270","150896640"
"07/07/2003 17:50:20.286","151875584"
"07/07/2003 17:50:35.286","153403392"
"07/07/2003 17:50:50.287","154718208"
"07/07/2003 17:51:05.287","155557888"
"07/07/2003 17:51:20.288","156950528"
"07/07/2003 17:51:35.288","158031872"
"07/07/2003 17:51:50.289","159526912"
"07/07/2003 17:52:05.289","159625216"
"07/07/2003 17:52:20.290","159625216"
"07/07/2003 17:52:35.290","159625216"
"07/07/2003 17:52:50.291","159625216"
"07/07/2003 17:53:05.291","159559680"
"07/07/2003 17:53:20.292","159559680"
"07/07/2003 17:53:35.292","159559680"
"07/07/2003 17:53:50.293","159559680"
"07/07/2003 17:54:05.293","159559680"
"07/07/2003 17:54:20.294","159563776"
"07/07/2003 17:54:35.294","159563776"
"07/07/2003 17:54:50.295","159563776"
"07/07/2003 17:55:05.295","159563776"
"07/07/2003 17:55:20.295","159563776"
"07/07/2003 17:55:35.296","159563776"
"07/07/2003 17:55:50.296","159563776"
"07/07/2003 17:56:05.297","159563776"
"07/07/2003 17:56:20.297","159563776"
"07/07/2003 17:56:35.298","159563776"
"07/07/2003 17:56:50.298","159563776"
"07/07/2003 17:57:05.299","159563776"
"07/07/2003 17:57:20.299","159563776"
"07/07/2003 17:57:35.300","159563776"
"07/07/2003 17:57:50.300","159563776"
"07/07/2003 17:58:05.301","159563776"
"07/07/2003 17:58:20.301","159563776"
"07/07/2003 17:58:35.302","159563776"
"07/07/2003 17:58:50.302","159563776"
"07/07/2003 17:59:05.303","159563776"
"07/07/2003 17:59:20.303","159563776"


Apache was compiled on MS VC++ 6.0
Comment 1 Mads Toftum 2003-11-17 02:47:24 UTC
What's your setting for SSLSessionCache?
Does this still happen with the latest version of Apache?
Comment 2 Jos 2003-11-17 12:06:36 UTC
Our configuration is:

Listen 443
AddType application/x-x509-ca-cert .crt
AddType application/x-pkcs7-crl    .crl
SSLPassPhraseDialog  builtin
SSLSessionCache         dbm:logs/ssl_scache
SSLSessionCacheTimeout  300
SSLMutex  default
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin

<VirtualHost _default_:443>
	<Directory "k:/com/paginas">
	    Options Indexes FollowSymLinks
	    AllowOverride None
	</Directory>

	ScriptAlias /cgi-bin/ "k:/com/cgi-bin/"
	<Directory "k:/com/cgi-bin">
	    AllowOverride None
	    Options Indexes Includes ExecCGI
	    Order allow,deny
	    Allow from all
	</Directory>

	DocumentRoot "k:/com/paginas"
	ServerName xxx.xxxxxxx.xx
	ServerAdmin you@your.address
	
	ErrorLog c:/apache2/logs/ssl_error.log
	TransferLog c:/apache2/logs/ssl_access.log
	
	SSLEngine on
	SSLCipherSuite HIGH:MEDIUM

	SSLCertificateFile c:/apache2/conf/ssl.crt/apache.crt
	SSLCertificateKeyFile c:/apache2/conf/ssl.key/apache.key
	SSLCACertificateFile c:/apache2/conf/ssl.ca/ca.cer
	
	SSLVerifyClient require
	SSLVerifyDepth 1
	SSLOptions +ExportCertData		
	
	<Files ~ "\.(cgi|shtml|dll|phtml|php3?)$">
	    SSLOptions +StdEnvVars
	</Files>
	<Directory "k:/com/cgi-bin">
	    SSLOptions +StdEnvVars
	</Directory>
	
	SetEnvIf User-Agent ".*MSIE.*" \
	         nokeepalive ssl-unclean-shutdown \
	         downgrade-1.0 force-response-1.0		         	
	         
</VirtualHost>                                  



With the latest Apache version (2.0.48) still happens
Comment 3 Sergei Zhirikov 2004-04-01 11:05:29 UTC
I have checked this issue with Apache 2.0.49. Indeed, the problem exists with
dbm session cache. But with shm everything looks OK.
Comment 4 Joe Orton 2004-04-01 14:00:48 UTC
Bug 26562 tracked down two issues which might affect you in 2.0.49:

1. some versions of OpenSSL have a memory leak in the "blinding" structures when
used from a threaded server

2. there was a memory leak in the use of the session cache

Bug 25667 has a memory leak in the dbm session cache.  Please reopen if the
problem is none of the above.

*** This bug has been marked as a duplicate of 25667 ***