Bug 21926 - Lot of zombi <defunct> with php in cgi
Summary: Lot of zombi <defunct> with php in cgi
Status: CLOSED DUPLICATE of bug 21737
Alias: None
Product: Apache httpd-1.3
Classification: Unclassified
Component: core (show other bugs)
Version: 1.3.28
Hardware: PC Linux
: P3 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-28 10:16 UTC by tchesmeli
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tchesmeli 2003-07-28 10:16:25 UTC
I have upgrade to apache 1.3.28 (security fix), and i'm running php in cgi mode
with suexec. All was vorking fine with apache 1.3.27 but now, i got severall php
process in Zombi <defunct>. If i restart apache (restart ou graceful) all this
zombi process are killed, but after some minute i got some php defunct.

I have try to upgrade php, but problem is still here.

Here my config:

#!/bin/sh
##
##  config.status -- APACI auto-generated configuration restore script
##
##  Use this shell script to re-run the APACI configure script for
##  restoring your configuration. Additional parameters can be supplied.
##

./configure \
"--with-layout=Slackware" \
"--enable-module=most" \
"--enable-shared=max" \
"--manualdir=/var/www/htdocs/manual" \
"--enable-rule=eapi" \
"--enable-suexec" \
"--suexec-caller=nobody" \
"--suexec-docroot=/home" \
"--suexec-logfile=/var/log/apache/suexec_log" \
"--suexec-uidmin=100" \
"--suexec-safepath=/usr/local/bin:/usr/bin:/bin:/home/default/cgi" \
"$@"

If you need additional information, let me know.
Comment 1 Mads Toftum 2003-07-28 10:33:27 UTC

*** This bug has been marked as a duplicate of 21737 ***