Bug 22199 - Unable to read file after particular size is exceeded
Summary: Unable to read file after particular size is exceeded
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 1.5.1
Hardware: PC All
: P3 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
Depends on:
Reported: 2003-08-07 06:37 UTC by Anand Iyer
Modified: 2005-03-20 17:06 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Anand Iyer 2003-08-07 06:37:59 UTC

We are creating an XLS file using HSSF. When the file content exceeds a 
particular size, we are not able to open the file in MS Excel. The same file 
opens if a few records are reduced. The XLS file is created using a Java 

Also in the same file, when it is in the openable size, a specific cell style 
that I am applying repeatedly stops getting applied after some loops. Opening 
the file in MS Excel and applying the same gives a 'No more fonts may be 
applied in this workbook' error.

We tried using 1.8.0 dev build and it still does not work.

Any help will be appreciated.

Comment 1 Andy Oliver 2003-08-07 14:59:47 UTC
please try 2.0-pre3 -  this sounds like the concurrency bug.
Comment 2 Anand Iyer 2003-08-21 12:07:28 UTC
As mentioned by you we have used version 2.0-pre3.
The same problem was coming with this version also.

Later we changed our code to reduce the number of cellstyles and fonts applied 
to a worksheet.
(The cellstyles and fonts are now applied to a couple of rows and rest of the 
worksheet uses default values.)
After this change our code is working with version  2.0-pre3, but it is still 
not working with older version and
is giving the error "Cannot open file" for large file size.

Since the version 2.0-pre3 is not a released version we cannot use it in 
Can you please provide the equivalent released version which will solve our 

Comment 3 Avik Sengupta 2003-10-30 18:41:45 UTC
From the last report, it looks like the actual bug is solved. The poster's issue
seems to be release nomenclature. So marking this bug fixed.

Anand, trust your own unit tests more that what we call a release! In any case,
2.0 is coming soon!