Bug 22318 - Apache Hangs with Excessive Warnings
Summary: Apache Hangs with Excessive Warnings
Status: CLOSED DUPLICATE of bug 22030
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.0.40
Hardware: PC Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-11 18:05 UTC by Al Gifford
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Al Gifford 2003-08-11 18:05:21 UTC
If too many warning messages are generated by a script apache hangs...

Steps to reproduce...
1. Run the following script from the command line which generates 
uninitialized variable warnings...Everything works fine...
2. Run the same script as a CGI program and the server hangs...
3. Change the number of iterations to a lower number (like 5) and run 
again...Everything works fine...

Conclusion:  If the script generates too many warnings apache hangs



#!/usr/bin/perl -w

print "Content-type: text/html\n\n";
for(0 .. 100){
        print "yada: $id<br>\n";
}


Has anyone seen this before?  (Yes I know about use strict, but that would not 
expose the problem now would it?)
Comment 1 Al Gifford 2003-08-11 19:27:04 UTC
Oh, I almost forgot...You can also turn off warning messages by using the -X 
option and that will suppress warning messages and stop the script from 
hanging...e.g.

#!/usr/bin/perl -X

This is not a solution, but a temporary work around...



Comment 2 Al Gifford 2003-08-11 19:32:51 UTC
You can use

#!/bin/perl -X

to suppress warnings.  This is a work around but does not fix the bug.
Comment 3 Joshua Slive 2003-08-13 16:13:22 UTC

*** This bug has been marked as a duplicate of 22030 ***