Bug 22483 - cgid dies frequently
Summary: cgid dies frequently
Status: CLOSED DUPLICATE of bug 19849
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Other Modules (show other bugs)
Version: 2.0.47
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-16 12:40 UTC by Akop Pogosian
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Akop Pogosian 2003-08-16 12:40:39 UTC
I have upgraded one site to Apache 2.0.47 a week ago. Since then, the cgi script
execution stopped for some reason a couple of times and the users were greeted
with a 503 error. Restarting httpd fixed this problem. The error log contained
entries like this:

(3)No such process: cgid daemon is gone; is Apache terminating?:
/services/http/cgi-bin/user-errors.cgi, referer: 
followed by some URL.

This is a busy multi-user site with lots of cgi scripts often executing
simultaneously, so coming up with a way to reproduce this problem would be hard
if not impossible. We're using Apache 2.0.47 on Solaris 8 with cgiwrap.


-akop
Comment 1 Jeff Trawick 2003-08-22 11:47:25 UTC
Grab revision 1.152 of mod_cgid from 
http://cvs.apache.org/viewcvs.cgi/httpd-2.0/modules/generators/mod_cgid.c

(go down to where it says "Revision 1.152", right-click on the 1.152 link, and
download it.)

This will restart mod_cgid if it crashes, so it will be much more resiliant for
you and there shouldn't be any long-term failure such as you are encountering
now.  Unfortunately, we won't be able to do anything about an individual cgid
daemon crash without knowing what causes it, and from your report it seems that
getting doc (e.g., backtrace for any coredumps in case it is segfaulting, or
truss otherwise) will be difficult for you.

For now I'll close this as a dup of 19849, which reported (and fixed) the issue
of mod_cgid not restarting the daemon after a crash, and if you can get doc on
an individual crash then re-open the PR and post the doc.




*** This bug has been marked as a duplicate of 19849 ***