Bug 23144 - junit filterstack should also filter out sun.reflect.* stuff
Summary: junit filterstack should also filter out sun.reflect.* stuff
Status: RESOLVED DUPLICATE of bug 22758
Alias: None
Product: Ant
Classification: Unclassified
Component: Optional Tasks (show other bugs)
Version: 1.5.4
Hardware: PC Windows XP
: P3 minor (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2003-09-12 17:46 UTC by Gunnlaugur Thor Briem
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments
Patch to improve stack trace filtering (898 bytes, patch)
2003-09-12 17:47 UTC, Gunnlaugur Thor Briem
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gunnlaugur Thor Briem 2003-09-12 17:46:40 UTC
In the <junit> task, the filterstack attribute causes lines containing
particular strings to be filtered out of stack traces in junit output,
to make the stack traces cleaner. The lines removed have to do with the
junit test invocation glue. The current implementation doesn't quite
finish the job; at least in J2SDK 1.4.2_01 on Windows, and Ant 1.5.4,
I get these lines:

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

I will attach a patch to make the stack filter remove these as well.
Comment 1 Gunnlaugur Thor Briem 2003-09-12 17:47:49 UTC
Created attachment 8190 [details]
Patch to improve stack trace filtering
Comment 2 Gunnlaugur Thor Briem 2003-09-12 17:56:38 UTC
(The patch is against the CVS head, not against the 1.5 branch or any tag)
Comment 3 J.M. (Martijn) Kruithof 2003-09-12 19:20:01 UTC

*** This bug has been marked as a duplicate of 22758 ***